Information
- Products: Sparkrock 2016, release 9.06 and later
- Summary: Due to an error you are not able to post the Payment Journal after the file has been exported and transmitted to the bank
Details
- You are not able to post the Payment Journal
- Sparkrock 2016 displays this error:
Error message: Check Transmitted must be equal to "Yes" in Gen.Journal Line: Journal Template Name=[X], Journal Batch Name =[X], Line No.=[20000]. The current value is "No" although the file was transmitted. - After you try to transmit the file again Sparkrock 2016 displays another error:
Error message: The export file, [file name], has already been transmitted.
Cause
When you transmit the file in the Payment Journal, the file is moved from the Export folder to Transmit. At the same time, the Check Transmitted field on the Payment Journal is selected indicating that the file was successfully transmitted to the bank. Sometimes the file is transferred from the Export folder to Transmit but the field Check Transmitted remains unselected, and this causes the error when you try to post the payment batch.
Impact / Risks
The Journal cannot be posted.
Resolution
Currently, there is no resolution to this issue. However, there is a workaround.
Workaround
- Check the Cheque Transmitted column in the payment journal to make sure all payments have been transmitted.
Note: If they have not been transmitted there will not be a checkmark in this field. - Check the exported file number. To check the export file number, follow these steps:
- Click the Application button (located In the top-left corner of the window). The Application menu displays.
- Click Help and then click About This Page.
- Expand Table Fields and look for the column Export File Name (e.g., EFT00058)
- Open the Transmit folder and look for the file with the same number as you saw in the Export File Name field.
Note: You can find the path of the Transmit folder in the CPA Trans. Program Path field under the Transfer tab on the Bank Account. Ensure the Transmit folder is present on the same path configured here. If the folder is not there then it needs to be restored, to do this, you can either locate where the folder has been moved and move it back to the correct location or recreate the folder using the same name present in the configuration of the Bank Account. - If you find the file, move it from the Transmit folder to the Export folder.
- If the file is not in the Transmit folder, copy any file in the folder and paste it to the Export folder. Rename the file to the number that was in the Export File Name field (e.g., EFT00058).
- Open the Payment Journal and Transmit the payments again.
Related Information
A permanent resolution is currently in testing. Updates will be added in this document when testing is complete.
Update History
Dates and actions pertinent to the history of this issue.
Date | Details | Link |
2018 | Cases identified this issue | |
12/10/2018 | Resolution to this issue is in testing | |
14/04/2019 | The Payroll Journal also encounters EFT troubleshooting. This documentation now reflects the update. | Discontinued in this article |
12/06/2019 | This document was a collection of both EFT Payment and Payroll Journal Troubleshooting. There are now 2 Knowledge Base articles. This one is only Payment Journal related. | EFT Payroll Journal Troubleshooting |
05/09/2022 | Expanded note in step #3 of the Workaround section |
Keywords/tags
EFT; Troubleshooting; Payment Journal
Attachment
N/A
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